Auxy 5.3 Update / Ableton Link bug


#82

What the?


#83

01%20pm


Link has been completely broken for three weeks now, which is three weeks too long when you’re charging a monthly subscription.

To make matters worse, there has been zero communication.

It’s just not good enough.


#84

Sorry for the inconvenience! It’s tricky to track down this problem, especially since we haven’t changed anything related to Link in the last update. Also, this has not been reported by anyone else except for you guys, and when we try it out it works as expected. Just did another test round with Groovebox and it seemed to work just fine.

Could you send an email (from within the app) to support and explain steps for reproducing so we can invest further?

And please email any bug reports to our support email in the future so that we can handle them properly.


#85

It’s 100% reproducible for me.

  1. Open Auxy and enable Link.
  2. Open another app (I’ve tried about a dozen) and enable Link.

(steps 1 and 2 can be reversed)

  1. It breaks
  • Auxy won’t play.
  • Session will sometimes stop all other apps.
  • Session will sometimes change BPM to 999.

Not for me.


#86

I sent an email about it (basically just lifted what I wrote here since there’s nothing else to add).

Exactly what @blakkaz put above is how to reproduce. With Link enabled, and nothing else connected, Auxy works fine. When trying to press play in Auxy with any other Link connected app ALSO playing, Auxy primes as though it’s going to play (play button changes to flashing indicating it’s getting ready) but it never plays.

I also get crazy tempo jumping to 999. The connected app will continue to play but Auxy does not. I’ve tried this across all the Ampify apps and Gadget. I’ve tried it on iPhone SE and iPad 2017, both running latest iOS. Also tried a hard reset on the iPad, issue persists.


#87

Out of curiosity, how hard have you attempted to recreate these bugs? Have you tried any other apps aside from Grovebox? I’m just curious as to how individuals have had 0% success rate at all with using link despite countless testings, yet you’ve had only 100% success rates.


#88

Why don’t you send THEM (@lenberg) your device + specs? It may be a bug that only is reproducible on certain devices.


#89

0% of people who are actively complaining on this forum :stuck_out_tongue:

Might be a stretch to say that Link works for 0% of people who use Auxy.


#90

blakkaz:
iPad Pro 10.5"
iPad 2018
iPhone XS

All on latest OS.

icsleepers:
iPad 2017
iPhone SE

All on latest OS.


If anyone else is willing to help test, that’d be great*.
I’d really like to get to the bottom of this.

* The Ampify apps (Groovebox, Blocs Wave etc…) support Link and are free to try.


#91

I connected Auxy to an app called Patterning via Link and it worked just fine. Both apps played and paused seamlessly, the tempos synced, and nothing crashed.

Specs:
iPad mini
2nd generation
Latest IOS

Edit:
Tried this again multiple times with the same results.


#92

Thanks. :+1:


I couldn’t get Auxy + Patterning to Link…

iPad Pro 10.5 (iOS 12.1.4)


#93

@V-M @blakkaz frankly, this behavior is bizarre lol. I could try Auxy and ApeMatrix I guess, I don’t have a ton of apps with Link that also have independent play buttons / sequencers. Lemme fire it up in a min, kids are occupied with a movie… for now…


#94

I’ve spent the past hour trying every possible combination of apps and setups I could think of.
The moment Auxy is added, everything breaks…

¯\_(ツ)_/¯


#95

I have it working with Reason Compact now, Medly, Egoist. And Blocs Wave. So I’m super confused now.


#96

Starting fresh. Open Blocs, hit play. Go back to home screen while it’s playing, open Auxy, hit play - suddenly it works.

In all fairness, I did install this fresh on the iPad just now. So… not sure what the hell is going on at this point.


#97

Redownloaded Blocs on my phone (already had Auxy still), set both up for Link, played Blocs first, then Auxy, all fine now. Wtf.


#98
  1. Open Blocs Wave & hit play (BPM @ 120)
  2. Back to home screen with Blocs still playing
  3. Open Auxy
  4. BPM jumped to 300 in Auxy and 999 in Blocs Wave (actual BPM was 999) :-1:
  5. Auxy won’t play :-1:

#99

…and now it’s not lol. So at the very least this is incredibly inconsistent.


#100

Yeah I’ve tried on both the iPad and iPhone again now and I can’t get it working at all. Unsure what’s going on (last attempt was Auxy and Reason Compact).

So, whatever. I can’t think of how to reliably test this and frankly I’m kind of over it.


#101

I pressed play on reason, switched to Auxy and pressed play, everything works fine. What the hecks is going on here?